Vodacom SIM Number Not Auto-updating on G-web and on physical Ultra device

Vodacom SIM Number Not Auto-updating on G-web and on physical Ultra device

Symptom: 

An incorrect or default mobile number (+000000000) is displayed on the device information page on the G-web platform instead of your Vodacom SIM number. Additionally, you will see a screen with the telephone icon only if you try retrieve the number on the menu screen of the physical Ultra device. 
Problem: 

This issue occurs when a Vodacom SIM card is installed into the external sim slot. The G-web platform does not update the built-in MTN SIM number to the new Vodacom SIM number. In some cases, a default number (+000000000) might be displayed when the Vodacom SIM is installed after a factory reset.
Cause: 

Vodacom has recently changed their USSD structure, and our system is no longer able to automatically retrieve the number using the previous scenario. Unfortunately, this cannot be resolved unless Vodacom reverts the USSD structure.
Temporary Solution:
  1. Install the Vodacom SIM card in a working mobile phone.
  2. Retrieve your Vodacom mobile number from the SIM card using SMS or a phone call.
  3. Re-install the Vodacom SIM card in the Ultra device.
  4. Update the mobile number on the G-web platform manually. This can be done by any user with access to the device information page on G-web.
Permanent Solution: 

Our Research and Development teams are working on improving the process to notify customers about the need to retrieve and update their Vodacom SIM number on the G-web platform manually. We apologize for any inconvenience this may cause.
Note: 

This is a temporary workaround until a permanent solution is implemented by our Research and Development teams.